В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
аида206
аида206
09.06.2022 16:59 •  Информатика

Используя цикл while, напишите программу, вычисляющую сумму квадратов чисел от 1 до введенного целого числа n

Ответ:
Налим12
Налим12
13.10.2020 21:54

program p;

var i:integer;

s,N:integer;

begin

readln(N);

s:=1;

For i:=2 to N do S:=S+i*i;

Writeln(S);

readln;

end.

Объяснение:

0,0(0 оценок)
Ответ:
pipidon17
pipidon17
13.10.2020 21:54

Код ниже

Объяснение:

program sumSquared;

var i, n, S: integer;

begin

   writeln('Введите число n: ');

   readln(n);

   S := 0;

   i := 1;

   while i <= n do begin

       S := S + i*i;

       i := i + 1;

       end;

    writeln('Сумма квадратов чисел S = ', S);    

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?