В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Halula
Halula
19.07.2021 16:33 •  Информатика

Написать программу которая будет переводить биты в килобайты и наоборот ​

Ответ:
настя7187
настя7187
13.10.2020 21:27

#include <iostream>

using namespace std;

int main()

{

   float a;

   int b;

   double  c;

   cout<<"Choose mode: 1 - KB to bit, 2 - bit to KB :";

   cin>>b;

   switch(b)

   {

   case 1:

   cout<<"Enter KByte count :"; cin>>a;

   c = a * 8 * 1024;  

   cout <<a<<" KByte = "<<c<<" bit";

   break;

   

   case 2:

   cout<<"Enter bit count :"; cin>>a;

   c = a /1024/8;  

   cout <<a<<" bit= "<<c<<" KByte";    

   break;

   }

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?