В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
cdf412
cdf412
05.04.2022 05:49 •  Информатика

Составьте программу в Pascal abc, которая с клавиатуры позволяет ввести количество информации в мегабайтах, килобайтах, байтах и битах. В результате нужно получить количество информации в битах.

Ответ:
rizakovaarina
rizakovaarina
13.10.2020 21:22

var mb,kb,byte,bit, result : Real;

begin

write('Mb. = '); readln(mb);

write('Kb. = '); readln(kb);

write('Byte = '); readln(byte);

write('Bit = '); readln(bit);

result := mb * 1014 * 1024 * 8;

result := result + (kb * 1024 * 8);

result := result + (byte * 8);

result := result + bit;

writeln(result:0:2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?