В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Mister2211
Mister2211
12.03.2020 18:00 •  Информатика

Напишите программу в паскале , которая зная секунды, за которые десятиклассник пробежал
2000 метров, а так же его пол, выставляет отметку по этой дисциплине.

Ответ:
V1a9
V1a9
13.10.2020 20:31

Объяснение:

var a,b,s,o:integer;

begin

 o := 0;

 writeln('введите количество секунд');

 readln(a);

 writeln('1.муж  2.жен');

 readln(b);

 s:=0;

 if b = 1 then  

 begin

   if (a <= 400) and (s=0) then

     begin

     o := 5;

     s := s+1;

     end;

   if (a <= 500) and (s=0) then

     begin

     o := 4;

     s := s+1;

     end;

   if (a <= 600) and (s=0) then

     begin

     o := 3;

     s := s+1;

     end;

   if (a <= 700) and (s=0) then

     begin

     o := 2;

     s := s+1;

     end;

 end

 else

 begin

   if (a <= 500) and (s=0) then

     begin

     o := 5;

     s := s+1;

     end;

   if (a <= 600) and (s=0) then

     begin

     o := 4;

     s := s+1;

     end;

   if (a <= 700) and (s=0) then

     begin

     o := 3;

     s := s+1;

     end;

   if (a <= 800) and (s=0) then

     begin

     o := 2;

     s := s+1;

     end;

 end;

 writeln('оценка: ',o)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?