В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Totiva
Totiva
25.01.2021 18:10 •  Информатика

Написать программу, которая суммирует 12 любых чисел (вводит пользователь или генератор случайных чисел). Использовать цикл for. Переменных не более 5 шт. и использовать цикл While. PascalABC. ​

Ответ:
jvdvzkris
jvdvzkris
09.08.2020 22:38

1) Цикл for

uses crt;

var j,count,i:integer;

begin

j:=0;

for i:=1 to 12 do

begin

 readln(count);

 j:=j+count;

end;

writeln(j);

end.

2) Цикл While

uses crt;

var j,count,i:integer;

begin

j:=0;

i:=0;

while i < 12 do

begin

 readln(count);

 j:=j+count;

 i:=i+1;

end;

writeln(j);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?