В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
21.03.2023 10:00 •  Информатика

Составить программу нахождения минимального элемента кратного 7 среди вводимых с клавиатуры целых трехзначных чисел. Числа вводятся до тех пор, пока не введено число 0

Ответ:
auutumn1
auutumn1
13.10.2020 19:25

program z1;

var s, a:Integer;

begin

a:=999;

readln(s);

while s<> 0 do begin

if (s mod 7 =0) and (s<a) then a:=s;

readln(s);

end;

writeln(a);

end .

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?