В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
katyasaveleva2001
katyasaveleva2001
10.07.2020 10:59 •  Информатика

Нужно написать программу на языке Паскаль
Условие:
Напишите программу,которая вводит с клавиатуры 3 целых числа и записывает в логическую переменную True,если среди введенных чисел есть хотя бы одно трехзначное

Ответ:
nata960
nata960
13.10.2020 19:06

var a,b,c,x:integer;

var true : array [1..3] Of integer ;

begin

readln(a,b,c);

if (a div 100 < 10 )and (a div 100 > 1) then

begin

True[1]:=a;

True[2]:=b;

True[3]:=c;

end;

if (b div 100 < 10 )and (b div 100 > 1) then

begin

True[1]:=a;

True[2]:=b;

True[3]:=c;

end;

if (c div 100 < 10 )and (c div 100 > 1) then

begin

True[1]:=a;

True[2]:=b;

True[3]:=c;

end;

write(true);

end.

Объяснение:

       если не надо в конце выводить true то можешь просто удалить эту строку

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?