В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
DenisGaleev
DenisGaleev
02.01.2023 16:42 •  Информатика

Напишите программу которая выводит случайное число в диапазоне от a до b.После этого вводится еще одно вещественное число. Выведите отдельно целую часть и дробную часть произведения случайного целого числа на введенное вещественное

Ответ:
nastyyanokogloStasya
nastyyanokogloStasya
23.04.2020 01:30

var a, b: real; i: integer;

begin  

randomize;  

readln(a,b);  

for i:= 1 to 5 do    

write((Random()*(b-a)+a):0:3, ' ');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?