В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
baka8
baka8
26.11.2020 22:41 •  Информатика

Ребят занятие через 30 мин ( паскаль)
1.Напишите программу, которая в последовательности целых чисел определяет количество отрицательных чисел и сумму положительных. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: количество отрицательных чисел и сумму положительных.
2.Напишите программу, которая в последовательности целых чисел определяет максимальное и минимальное число и выводит сумму этих чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000, но не может быть меньше 2. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число — сумму максимального и минимального числа.

Ответ:
dariadariadaria2
dariadariadaria2
03.08.2020 06:42

Задача 1:

var a,s1,s2: integer;

begin

s1:=0;

s2:=0;

repeat

readln(a);

if (a<0) then s1:=s1+1

else if (a>0) then s2:=s2+a;

until (a=0);  

writeln('Количество отрицательных: ',s1);

writeln('Сумма положительных: ',s2);

end.

Задача 2:

var a,i,n,min,max: integer;

begin

write('Введите кол-во чисел в последовательности: ');

readln(n);

write('Введите ',1,' число: ');

readln(a);

max:=n;

min:=n;

for i:=2 to n do

 begin

 write('Введите ',i,' число: ');

 readln(a);

 if (a>max) then max:=a;

 if (a<min) then min:=a;

 end;

writeln('Минимальное число: ',min);

writeln('Максимальное число: ',max);

writeln('Их сумма: ',min+max);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?