В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vika200920001
vika200920001
14.02.2023 08:05 •  Информатика

Напишите программу на С++, которая заменяет в символьной строке все буквы a на буквы b (латинские, строчные). Решение с комментариями к
каждой строке кода. Комментарии должны пояснять, что происходит в каждой строке программы, для чего она нужна и т.п.

Входные данные
Входная строка содержит символы латинского алфавита, как строчные, так и заглавные.

Выходные данные
Программа должна заменить во всей строке строчные буквы a на буквы b и вывести в первой строке получившуюся символьную строку, а во второй – количество выполненных замен.

Примеры
входные данные
aabbccabadef
выходные данные
ccbbbdef
4

Ответ:
Kir2905
Kir2905
13.10.2020 14:07

#include <stdio.h>

#include <locale.h>

#include <string.h>

#include <stdlib.h>

//Замена

#define a 'a'

#define b 'b'

//Размер строки

#define n 255

int main(){

setlocale(LC_ALL, "rus");

char s[n];

printf("\n >> Введите строку:\n << ");

fgets(s, n, stdin);

for (int i = 0; i < strlen(s); i++)

 if (s[i] == a)

 s[i] = b;

printf("\n >> Результат:\n >> ");

fputs(s, stdout);

system("pause>>void");

return 0;

}

Объяснение:так?

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?