В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
04812
04812
28.07.2020 06:04 •  Информатика

Дан целочисленный массив из n элементов. Элементы массива могут принимать целые значения от 0 до 10 000 включительно (такие числа будет вводить пользователь, это проверять не нужно). Напишите программу, которая находит максимальный из оканчивающихся на 3 элементов массива, затем увеличивает все элементы массива, кратные 8, на значение этого элемента, и выводит в строку. Если в массиве нет оканчивающихся на 3 элементов, он остаётся без изменений. Например, из массива

7, 23, 18, 24, 33, 48, 80

программа должна получить массив

7, 23, 18, 57, 33, 81, 113

Ответ:

const n = 7;

var a: array [1..n] of integer;

i, max: integer;

begin

   for i := 1 to n do

   begin

       write('Введите ', i, ' элемент: ');

       readln(a[i]);

   end;

   

   max := 0;

   for i := 1 to n do

   begin

       if (a[i] mod 10 = 3) and (a[i] > max) then

           max := a[i];

   end;

   

   for i := 1 to n do

   begin

       if (a[i] mod 8 = 0) then

           a[i] := a[i] + max;

   end;

   

   

   for i := 1 to n do

   begin

       write(a[i], ' ');

   end;

   writeln();

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?