В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Laurka11
Laurka11
29.04.2021 11:22 •  Информатика

Нужно написать программу на c++, которая будет рисовать полый квадрат из решеток(#) используя вложенный цикл.
Вводится одна переменная: длина стороны

Ответ:
Merlin33
Merlin33
23.08.2020 23:20

#include <iostream>

int main()

{

   int len, i, j;

   // Русский язык в консоли

   setlocale(LC_ALL, "Russian");

   std::cout << "Введите длину стороны: ";

   std::cin >> len;

   for (i = 0; i < len; i++)

   {

       for (j = 0; j < len; j++)

       {

           if ((j == 0) || (j == len - 1) || (i == 0) || (i == len - 1)) std::cout << "#";

           else std::cout << " ";

       }

       std::cout << std::endl;

   }

   

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?