В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kirovaalex16
kirovaalex16
11.06.2021 02:25 •  Информатика

ПИТОН

Напишите программу, которая заполняет массив из 10 элементов случайными числами в диапазоне [100,300] и выводит его на экран. После этого на экран выводятся средние цифры (число десятков) всех чисел, записанных в массив.Пример:Массив: 142 324 135 257 167 295 126 223 138 270 Число десятков: 4 2 3 5 6 9 2 2 3 7

Ответ:
valeryahasko070
valeryahasko070
14.08.2020 22:56

import random

for i in range(10):

   a=random.randint(100,300)

   print()

   print('Число:', a,end=' ')

   s=(a%100)//10

   print('Средняя цифра:', s,end=' ')

Объяснение:


ПИТОН Напишите программу, которая заполняет массив из 10 элементов случайными числами в диапазоне [1
ПИТОН Напишите программу, которая заполняет массив из 10 элементов случайными числами в диапазоне [1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?