В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Лелечка43
Лелечка43
19.01.2023 17:39 •  Информатика

составьте программу для чтения отрывка из текста.Переключение его на Перевертыш и передача его на печать в том же варианте. Слово перевертыша переводится следующим образом: буквы, стоящие до первого гласного, перемещаются до конца слова и соединяются с окончанием quot; циусquot;. Например.
a)" кот в сапогах " -- " откциус вциус апогахсциус"
b) "пример перевода" -- " имерпрциус ереводапциус"

Ответ:
привки228
привки228
13.10.2020 07:50

// PascalABC.Net

var vowel: set of char = ['а', 'у', 'о', 'ы', 'и', 'э', 'я', 'ю', 'ё', 'е'];

s, substr: string;

begin

  s := 'кот в сапогах';

  var words := s.Split(' ');

  for var i := 0 to words.length - 1 do

  begin

      for var j := 1 to words[i].Length do

          if words[i][j] in vowel then

          begin

              substr := Copy(words[i], 1, j-1);

              Delete(words[i], 1, j-1);

              words[i] += substr;

              break;

          end;

      words[i] += 'циус';

  end;

  writeln(words.JoinIntoString(' '));

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?