В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
viktorrudnik53
viktorrudnik53
20.06.2021 06:14 •  Информатика

Написать программу, которая заполняет массив А[1..50] случайными числами из диапазона (-30, 30), подсчитывает сколько раз встречается число 0.

Ответ:
vitay123
vitay123
30.07.2020 12:44

var s, i: integer;

a:array[1..50] of integer;

begin

for i:=1 to 50 do

begin

a[i]:=30-random(61);

write(a[i],' ');

end;

for i:=1 to 50 do

s:=0;

begin

if a[i]=0 then

s:=s+1

end;

writeln('Нулей в массиве = ', s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?