В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
TashaDu
TashaDu
17.04.2020 12:41 •  Информатика

Тест по теме «Программирование на языке Pascal»
1) С какого слова обычно начинается раздел операторов?
a) Uses;
b) Begin;
c) Var;
d) Write.

2) Какая из переменных может не является целой?
a) a:=2;
b) b:=4 div 7;
c) d:=d / 6;
d) c:=-25.

3) Выделите верные утверждения. Чем отличаются команды Write(a) и Writeln(a)?
a) после выполнения Write(a) курсор не переводится на начало новой строки;
b) после выполнения Write(a) курсор переводится на начало новой строки;
c) после выполнения Writeln(a) курсор переводится на начало новой строки;
d) нет правильного ответа.

4) Операция Div позволяет найти:
a) результат деления одного числа на другое;
b) результат целочисленного деления одного числа на другое;
c) остаток от целочисленного деления;
d) нет правильного ответа.

5) Какое значение получит переменная a после выполнения серии команд?
a:=5;
b:=2;
a:=b * a - SQR(a)

a) 10; b) 15; c) 40; d) -15.

6) Что будет выведено на экран после выполнения серии команд?
a:=5;
b:=2;
a:=b-a mod 4;
write (`a=`, a);

a) a=1; b) a=2; c) a=0 ; d) a=-1.

7) Что будет выведено на экран после выполнения серии команд?
a:=4;
b:=2;
a:=b-a div 3;
write(a);

a) 2; b) 1; c) 5; d) 1.7.

8) Что будет выведено на экран после выполнения серии команд?
a:=4;
b:=8;
a:=a / b - 5;
write(abs(a));

a) 5.25; b) 4.75; c) 4.5; d) -4.5.

9) Переменная а является целой. В какой строке при использовании команды “присвоить значение” допущена ошибка?
a) a:=a / 5-1; b) a:=SQRT(a); c) a:=sqr(5); d) a:=abs(2*a).

10) Что означает в Pascal знак «;»?
a) конец цикла;
b) конец строки программы;
c) конец программы;
d) отделяет операторы друг от друга.

11) Поставьте в соответствие: какие переменные каким служебным словом описываются?
a) INTEGER 1. дробные
b) REAL 2. символьный
c) CHAR 3. строковый
d) STRING 4. целые

12) Раздел описаний VAR используется для описания:
a) констант;
b) переменных;
c) меток;
d) функций.

13) Чем заканчивается программа?
a) Var;
b) Program;
c) End;
d) Readln.

14) Укажите операторы вывода?
a) Read ();
b) Write ();
c) Writeln ();
d) Readln ().

15) Что означает знак := в языке программирования Pascal?
a) деление;
b) равенство;
c) сравнение;
d) присваивание.

16) Какое значение будет иметь переменная b после выполнения следующего фрагмента программы?
a:=4;
b:=2;
a:=a*a*b;
b:=a+b;

a) 38; b) 34; c) 16; d) 18.

17) Чему равно значение выражения sqrt(16)*2 - sqr(3)-20/5?
a) 5; b) -6; c) -5; d) 6.

18) Запишите значение переменной s, полученное в результате работы следующей программы:
Var s, k: integer;
Begin
s := 0;
for k := 3 to 7 do
s := s + 6;
writeln(s);
End.

a) 30; b) 36; c) 24; d) 16.

19) Поставьте в соответствие:
a) If 1. Оператор цикла с предусловием
b) For 2. Оператор ветвления
c) While 3. Оператор цикла с постусловием
d) Repeat 4. Оператор цикла с известным числом шагов

20) Какое имя объекта недопустимо в Pascal?
a) 167y;
b) UIP;
c) Tr15;
d) zima.

21) Выберите правильную запись выражения «А не равно 4».
a) А!;
b) А=4;
c) А==4;
d) А<>4.

22) Какое из нижеперечисленных утверждений верно?
a) If f>2 then а:=3; еlse a:=5;
b) If (f>2) then а=3; еlse a=5;
c) If f>2 then а:=3 еlse a:=5;
d) If (f>2) а:=3 еlse a:=5.

23) Запишите зна¬че¬ние переменной t, по¬лу¬чен¬ное в ре¬зуль¬та¬те работы сле¬ду¬ю¬щей программы.
Var s, t: integer;
Begin
t := 0;
for k := 4 to 7 do
t := t + 41;
writeln(t);
End.

24) Определите, что будет на¬пе¬ча¬та¬но в ре¬зуль¬та¬те работы сле¬ду¬ю¬щей программы.
Var r, k: integer;
Begin
r := 3;
for k :=4 downto 1 do
r := r*2;
write (r);
End.

25) В массиве D хра¬нят¬ся дан¬ные о ко¬ли¬че¬стве уче¬ни¬ков в клас¬сах (D[1] — ко¬ли¬че¬ство уче-ни¬ков в пер¬вом классе, D[2] — во вто¬ром и т. д.). Определите, какое число будет на¬пе¬ча-та¬но в ре¬зуль¬та¬те ра¬бо¬ты сле¬ду¬ю¬щей программы.
Var k, m: integer;
D: array[1..11] of integer;
Begin
D[1] := 20;
D[2] := 27;
D[3] := 19;
D[4] := 28;
D[5] := 26;
D[6] := 22;
D[7] := 24;
D[8] := 28;
D[9] := 26;
D[10] := 21;
D[11] := 27;
m := 0
for k := 1 to 11 do
if D[k] < 25 then
begin
m := D[k];
end;
writeln(k);
End.

Оценка "5" - 24-
Оценка «4» - 19-
Оценка «3» - 10-
Оценка «2» - менее

Ответ:
Kirillastrovskiy
Kirillastrovskiy
13.04.2020 17:30

ответ:1) (1 б.) Верные ответы: 3;

2) (1 б.) Верные ответы: 4;

3) (1 б.) Верные ответы: 1; 2;

4) (1 б.) Верные ответы: 3;

5) (1 б.) Верные ответы: 1;

6) (1 б.) Верные ответы: 3;

7) (1 б.) Верные ответы: 4;

8) (1 б.) Верные ответы: 1;

9) (1 б.) Верные ответы: 3;

10) (1 б.) Верные ответы: 3;

11) (1 б.) Верные ответы: 2;

12) (1 б.) Верные ответы: 3;

13) (1 б.) Верные ответы: 4;

14) (1 б.) Верные ответы: 1;

15) (1 б.) Верные ответы: 1; 2;

16) (1 б.) Верные ответы: 1;

17) (1 б.) Верные ответы: 2;

18) (1 б.) Верные ответы: 1;

19) (1 б.) Верные ответы: 3;

20) (1 б.) Верные ответы: 2;

21) (1 б.) Верные ответы: 2;

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?