В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
леон15
леон15
10.11.2020 16:46 •  Информатика

C++
Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке.
Входные данные:
Входная строка содержит три целых числа, разделённых пробелами.
Выходные данные:
Программа должна вывести количество одинаковых чисел из переданного ей набора или число 0, если все числа различные.

Ответ:
yiliamasegorova
yiliamasegorova
12.10.2020 23:15

#include <iostream>

int main()

{

int a, b, c;

std::cout << "Enter 3 Numbers: ";

std::cin >> a >> b >> c;

std::cout << "\n";

if (a==b && b==c)

   std::cout << "All numbers are the same";

if ((a==b && a!=c) || (a==c && a!=b) || (b==c &&b!=a))

   std::cout << "Two numbers are similar";

if ((a!=b) && (a!=c) && (b!=c))

   std::cout << 0;

return 0;

}

Объяснение:


C++ Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цеп
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?