В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
princess82
princess82
04.10.2021 08:46 •  Информатика

по информатике не шарю! 1. Написать программу, которая будет считать сумму введенных с клавиатуры чисел до тех пор, пока не будет введен ноль.
2. Написать программу (с циклом While) которая находит сумму всех четных чисел до 100.
3. Написать программу вывода квадратов всех натуральных чисел, не превосходящих данного числа N.
Пример: N=50 | 1 4 9 16 25 36 49

Ответ:
botagos210579
botagos210579
03.09.2020 20:50

Пишу на языке питон

№1

b=0

while True:

   a=int(input())

   b+=a

   if a == 0:

       break

print(b)

№2

a=0

b=0

while b!=100:

   b+=2

   a=a+b

   print(a)

№3

a=0

b=0

while b!=100:

   b+=2

   a=a+b

   print(a)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?