В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
aylincik930
aylincik930
18.11.2021 15:32 •  Информатика

Напишите программу на python, которая вычисляет средний рост учеников. Алгоритм должен в цикле пользователя ввести рост ученика. Цикл завершается, когда пользователь введет рост, равный нулю. Программа должна вывести средний рост учеников в классе.

Формат ввода
Вводятся целые числа одно за другим, на отдельных строках.

Формат вывода
Выводтся одно значение среднего роста

Ответ:
Kraddy14
Kraddy14
12.10.2020 22:47

n=0

s=0

a=1

while a!=0:

   a=int(input())

   n+=1

   s+=a

print(s/(n-1))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?