В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
katuxa65789
katuxa65789
12.04.2021 02:49 •  Информатика

Дано число n, n <=100 . Создайте массив n×n и заполните его по следующему правилу:
- числа на диагонали, идущей из правого верхнего в левый нижний угол, равны 1;
- числа, стоящие выше этой диагонали, равны 0;
- числа, стоящие ниже этой диагонали, равны 2.

Входные данные
Программа получает на вход число n.

Выходные данные
Необходимо вывести полученный массив. Числа разделяйте одним пробелом.

Примеры
входные данные
4
выходные данные
0 0 0 1
0 0 1 2
0 1 2 2
1 2 2 2
#include

using namespace std;

int main()
{
int a[100][100], n;
cin >> n;
for (int i = 0; i < n; i++) {
for (int j = 0; j < n; j++) {
if (i + j < n - 1)
a[ i ][ j ] = 0;
else if (i + j == n - 1)
a[i][j] = 1;
else
a[i][j] = 2;
}
cout << a[i][j];
cout << endl;
}
return 0;
}
не получается по-человечески вывести матрицу, особенно когда ставлю оператор for, знаю, тупая ошибка

Ответ:
kuzmichkinvale
kuzmichkinvale
12.10.2020 11:12

Объяснение:

cout << endl; Нужно поставить после первой фигурной скобки.

У тебя в столбик матрица выходит.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?