В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
temauvarov228
temauvarov228
21.04.2021 12:51 •  Информатика

решить задачу на Python,
Составить программу,которая в данной массиве из 40 случайных элементов от -5 до 5, которая определяет количество отрицательных элементов и находит сумму чисел, оканчивающихся на 4. Все элементы, оканчивающиеся на 4 выводит в порядке возрастания

Ответ:
qwerty2021
qwerty2021
12.10.2020 10:38

в условии не сказано, надо находить сумму чисел оканчивающихся на 4 в массиве из отрицательных элементов, или изначальном массиве. если узнаешь, отпиши, исправлю .

import random

number_list = [str(random.randint(-5, 5)) for n in range(40)]

negative_numbers = [i for i in number_list if int(i) < 0]

end_with_four = [number for number in number_list if number[-1] == '4']

amount = 0

for num in end_with_four:

   amount += int(num)

print('количество отрицательых элементов: ' + str(len(negative_numbers)))

print('сумма элементов оканчивающихся на 4: ' + str(amount))

end_with_four.sort()

for idk in end_with_four:

   print(idk, end = ' ')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?