В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
samsonovich12S1
samsonovich12S1
12.11.2020 00:01 •  Информатика

Написать программу, которая считает сумму: 1\3+2\4+3\5+...+n/(n+2). Переменная n вводится с клавиатуры

Ответ:
kamillavoice
kamillavoice
12.10.2020 10:36

уточняйте на каком языке программирования нужно написать.

Для примера напишу на С++, но алгоритм везде один и тот же.

int n = 0; // Создаём переменную n;

cin >> n; //Вводим n

double sum = 0.0; // Создаём переменную sum которая является дробью.

for(int i = 1; i<n; i++){ //Создаём цикл который будет выполняться n-количество раз.

sum+=(i/(i+2) // Считаем цикл за формулой

}

cout << sum; // Выводим окончательную суму.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?