В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
slava20syper
slava20syper
30.11.2022 00:00 •  Информатика

(Python) Вам нужно написать программу, которая за ввести оценки для четырёх учеников: Bill, Jane, John, Mary. В конце необходимо вывести среднюю оценку для всей группы, округлённую в большую сторону. Предполагайте, что пользователь вводит только числа в оценки. Средняя оценка вычисляется как среднее арифметическое - сумма всех оценок, делённая на количество учеников.
Что должно присутствовать в коде программы:

Каждую оценку нужно сохранять в словаре marks. В качестве ключей использовать имена учеников.
Для подсчёта суммы обращаться к каждой записи в словаре по ключу.

Ответ:
Rtyrtya
Rtyrtya
12.10.2020 08:08

marks = {'Bill': int(input()), 'Jane': int(input()), 'John': int(input()), 'Mary': int(input())}

average = 0

for key in marks.keys():

   average += marks[key]

print(round(average / 4))

'округлённую в большую сторону'

Если нужно округлять всегда в большую сторону(то есть из 4.1 выводить среднюю 5), то в начале программы пишешь:

import math

, а в конце вместо 'print(round(average / 4))', пишешь:

print(math.ceil(average / 4))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?