В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
MissEvaStar
MissEvaStar
10.04.2023 03:11 •  Информатика

с информатикой. Составить БЛОК-Схему и написать программу.

Ответ:
Masha72011
Masha72011
11.09.2020 22:49

Задача 1

var

 x1, y1, x2, y2, l: real;

begin

 Writeln('Введите значения (x1,y1,x2,y2)');

 Read(x1, y1, x2, y2);

 l := Sqrt(Sqr(x1 - x2) + Sqr(y1 - y2));

 Writeln('Расстояние: ', l:3:2);

end.

Тестовое решение:

Введите значения (x1,y1,x2,y2)

2 3 4 5

Расстояние: 2.83

Задача 2

var

 a, b, c, p, s: real;

begin

 Writeln('Введите ABC');

 Read(a, b, c);

 P := (a + b + c)/2;

 S := Sqrt(p * (p - a) * (p - b) * (p - c));

 Writeln('Площадь по Герону: ', S:3:2);

end.

Тестовое решение:

Введите ABC

2 3 4

Площадь по Герону: 2.90

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?