В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
agat2003
agat2003
07.03.2020 14:15 •  Информатика

Вам дана программа, в которой создается массив и выводится на экран а также вводятся 2 числа: n и k - количество элементов и значение первого элемента массива. Дополните программу таким образом, чтобы массив заполнялся по следующему правилу: каждый следующий элемент на три больше предыдущего.

#include
using namespace std;
int main() {
int a[100], n, k;
cin >> n >> k;
// место для вашего фрагмента программы
for (int i = 0; i < n; i++) {
cout << a[i] << " ";
}
return 0;
}

Формат входных данных
С клавиатуры вводится натуральное число n (n≤100) - количество элементов.

На следующей строке вводится целое число - первый элемент массива. Все числа по модулю не превосходят 10000.

Формат выходных данных
В качестве ответа выведите массив

Примечания
В задачу требуется отправлять только указанный фрагмент кода.

P.s язык программирования С++

Ответ:
ariana201723
ariana201723
12.10.2020 07:18

Объяснение:

a[0]=k;

for (int i = 1; i < n; i++) {

a[i]=a[i-1]+3;

}

0,0(0 оценок)
Ответ:
BigD13
BigD13
12.10.2020 07:18

   a[0] = k;

   for (int i = 1; i < n; i++)

       a[i] = a[i-1] + 3;

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?