В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Настя55251
Настя55251
17.06.2022 04:48 •  Информатика

1В результате выполнения программы
program my_klass;
var
a:integer;
begin
a:=25+24*2;
writeln ('улыбок');
end.
мы увидим на экране:
а) 73 улыбок; в) 'улыбок'; б) улыбок; г) улыбок73
2Чему будет равно значение переменной sum, после выполнения данной программы, если n = 389; n = 725; n = 345
Program pr1;
var sum,n:integer;
begin
writeln('Введите трехзначное число');
readln(n);
sum:=(n div 10)+(n div 15 mod 10)+(n div 6);
writeln('Сумма цифр числа = ',sum);
end.
3Какие из операторов присваивания не будет работать в программе с разделом описания переменных:
Var
n:integer;
Выберите вариант ответа:
1) 25:=n; 2) n:=2.5; 3) n=25; 4) n:=25
4Найти значение выражения:
55 div 10 + 14 =
205 mod 100 + 1 =
(32 mod 4 + 1) * 24 =
5Чему будет равно значение переменной sum, после выполнения данной программы, если X =479.

Program SumCifr;
Var X, Sum: integer;
Begin
Write(‘Введите трехзначное число: ');
ReadLn(X);
Sum:=5;
Sum:=Sum + X mod 10;
X:=X div 5;
Sum:=Sum + X mod 10;
X:=X div 4;
Sum:=Sum + X;
Write (' цифр = ',Sum)
End.

Ответ:
gogogold2208
gogogold2208
12.10.2020 02:55

1) улыбок(б)

2)

Для N 389: 107

Для N 725: 200

Для N 345: 97

3) Не будут работать 1 и 2

4)

55 div 10 + 14 = 19

205 mod 100 + 1 = 6

(32 mod 4 + 1) * 24 = 24

5) 42

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?