В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу нахождения площади высоты, радиусов вписанной и описанной окружности равностороннего треугольника со стороной а.​

Ответ:
4sasna
4sasna
12.10.2020 02:43

# Python 3.7.2

from math import sqrt

a = int(input())

h = sqrt(3) / 2 * a

r = a / (2 * sqrt(3))

R = a / sqrt(3)

print('Высота:', h)

print('Радиус вписанной окружности:', r)

print('Радиус описанной окружности:', R)

0,0(0 оценок)
Ответ:
Dimatrubilov
Dimatrubilov
12.10.2020 02:43

PascalABC.Net

procedure Rad(a: real; n: integer);var  R, R2: real;begin  R := a / (2 * sin(pi / n));  R2 := R * cos(pi / n);  Println('Радиус (Описаный): ', R);  Println('Радиус (Вписаный): ', R2);end;begin  var a := ReadReal('Введите A: ');  var n := ReadInteger('Введите N: ');  Rad(a, n);end.

Varian 2

program HappyCoder; var  R, R2, A: real;  n: integer; begin  Writeln('Введите A: ');  Read(A);  Writeln('Введите N: ');  Read(n);  R := a / (2 * sin(pi / n));  R2 := R * cos(pi / n);  Writeln('Радиус (Описаный): ', R:0:3);  Writeln('Радиус (Вписаный): ', R2:0:3); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?