В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
димасик138
димасик138
17.09.2022 03:22 •  Информатика

Нужно составить программу в Pascal ABC, которая будет разворачивать числа, например, 234=432​

Ответ:
ZaY40nOK
ZaY40nOK
27.08.2020 23:18

Var

n, m:integer;

a:byte;

Begin

readln(n);

m:=0;

while n>0 do begin

a:= n mod 10;

n:= n div 10

m:= m*10+a

end;

writeln(m) ;

End.

0,0(0 оценок)
Ответ:

Для любого количества символом/цифр

begin

 var stroka := ReadString('Введите число/слово');

 for var i := Length(stroka) downto 1 do

   stroka += stroka[i];

 Delete(stroka, 1, length(stroka) div 2);

 Println('Реверс: ', stroka);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?