В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
MAXguychenya
MAXguychenya
23.08.2022 06:50 •  Информатика

Паскаль
1.Написать программу, которая находит произведение цифр двух двузначных чисел.
2.Напишите программу, которая находит а% от b и b% от а.

Ответ:
Софалия
Софалия
11.10.2020 22:42

1.

program z1;

var a,b:integer;

begin

write('Введите 2 двузначных числа: ');

readln (a,b);

write('Произведение цифр числа ',a,' и числа ',b,' равно ',(a div 10) * (a mod 10) * (b div 10) * (b mod 10))

end.

2.

program z2;

var a,b:integer;

begin

write('Введите 2 числа: ');

readln (a,b);

writeln(a,'% от ',b,' равно ',b*a/100);

write(b,'% от ',a,' равно ',a*b/100)

end.

Объяснение:

Если во второй задаче надо найти какой процент составляет число а от числа b и какой процент составляет число b от а, то меняем строчки

writeln(a,'% от ',b,' равно ',b*a/100);

write(b,'% от ',a,' равно ',a*b/100)

на

writeln('Число ',a,' от числа ',b,' составляет ',a/b*100,'%');

write('Число ',b,' от числа ',a,' составляет ',b/a*100,'%')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?