В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
gayazhan
gayazhan
19.04.2021 02:34 •  Информатика

5. Напишите программу, которая заполняет массив из 10 элементов случайными числами на отрезке
[-2; 2] и находит произведение ненулевых элементов ​

Ответ:
девочка245
девочка245
11.10.2020 15:47

C# 8.0:

using System;

using System.Linq;

...

var Arr = RandomIntArr(-2,2,10);

Console.WriteLine(Arr.Where(x=>x!=0).Aggregate((x,y)=>x*y));

...

static int[] RandomIntArr(int Min, int Max, int ArrLen) {

   Random rnd = new Random();

   int[] Out = new int[ArrLen];

   for (int i = 0; i < ArrLen; i++)  Out[i] = rnd.Next(Min, Max+1);

   return Out;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?