В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Sobakopes
Sobakopes
27.04.2021 21:07 •  Информатика

СОСТАВИТЬ ПРОГРАММУ НА ПАСКАЛЕ!
Рассчитать сумму кубов всех положительных значений и их количество для функции

Составить программу для табулирования функции на промежутке [0;4] с шагом h=0,5.

Ответ:
ЛеркаXD
ЛеркаXD
11.10.2020 15:41

===== PascalABC/NET =====

begin

 var (a, b, h) := (0.0, 4.0, 0.5);

 var n := Trunc((b - a) / h) + 1; // количество точек

 var (s, k) := (0.0, 0);

 for var i := 0 to n - 1 do

 begin

   var x := a + i * h;

   var y := 3 * x * x + 2 * Cos(Cos(x));

   Writeln(x:3:1, y:20:15);

   if y > 0 then

   begin

     Inc(k);

     s += y ** 3

   end

 end;

 Println('Сумма кубов положительных значений функции равна', s);

 Println('Количество вошедших в сумму значений равно', k)

end.


СОСТАВИТЬ ПРОГРАММУ НА ПАСКАЛЕ! Рассчитать сумму кубов всех положительных значений и их количество д
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?