В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
10672
10672
15.04.2021 10:17 •  Информатика

Уровень E. Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи две одинаковые цифры, стоящие рядом.

Ответ:
DrNick
DrNick
11.10.2020 13:19

some_num = input()  

splited_num = list(some_num)

isSameNumNear = False

for index in range(len(splited_num)-1):

   if splited_num[index] == splited_num[index+1]: isSameNumNear = True  

print('2 цифры идут подряд' if isSameNumNear else 'Все цифры разные')


Уровень E. Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли
0,0(0 оценок)
Ответ:
ilyavip0412
ilyavip0412
11.10.2020 13:19

Если я правильно понял:

Объяснение:

n=input()

for i in range(0, len(n)-1):

  if n[i]==n[i+1]:

     print("YES")

     exit()

P.S. Отпиши если не работает

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?