В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
AzamatAmangaliev1
AzamatAmangaliev1
04.10.2020 08:02 •  Информатика

C++
Даны два массива чисел. Требуется вывести элементы первого массива (в том порядке, в каком они идут в первом массиве), которых нет во втором массиве.

Входные данные

Записано сначала число N - количество элементов в первом массиве, затем N чисел - элементы массива. Затем записано число M – количество элементов во втором массиве. Затем записаны элементы второго массива. Количество элементов каждого массива не превышает 100. Сами элементы -числа из диапазона int.

Выходные данные

Выведите те элементы первого массива, которых нет во втором в том порядке, в каком они идут в первом массиве.
Пример

Вход Выход
7
3 1 3 4 2 4 12
6
4 15 43 1 15 1
3 3 2 12

Ответ:
LionesBastia
LionesBastia
11.10.2020 11:37

#include <iostream>

#include <vector>

#include <algorithm>

using namespace std;

int main()

{

   vector <int> arr1;

   vector <int> arr2;

   int n;

   

   cin >> n;

   for(int i = 0 ; i < n ; ++i)

   {

       int temp; cin >> temp;

       arr1.push_back(temp);

   }

   cin >> n;

   for(int i = 0 ; i < n ; ++i)

   {

       int temp; cin >> temp;

       arr2.push_back(temp);

   }

   for(int i = 0 ; i < arr1.size() ; i++)

       if(find(arr2.begin(), arr2.end(), arr1[i]) == arr2.end())

           cout << arr1[i] << ' ';

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?