В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
12345678300
12345678300
24.11.2022 19:45 •  Информатика

ПАСКАЛЬ
Написать программу
Задачи на строки
Даны две произвольные строчки. Совпадают ли они побуквенно?

Ответ:
Флэшик
Флэшик
11.10.2020 11:24

program sovpadenie_strok;

uses crt;

var

s1,s2:string;

i:integer;

f:boolean;

begin

read(s1);

read(s2);

if (length(s1)=length(s2))then

begin

i:=1;

f:=false;

while(i<length(s1))and(f=false)

do

begin

if s1[i]<>s2[i] then f:=true;

i:=i+1

end;

if f=true then

write('Строки побуквенно не совпадают')

else

write('Строки побуквенно совпадают')

end

else

write('Строки разной длины')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?