В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
tumoannasehko
tumoannasehko
14.02.2023 13:33 •  Информатика

Задача 5
Написать программу, принимающую 1 аргумент — число от 0 до 200, и возвращающую True, если оно и False - иначе.
на Python

Ответ:
alsusarip
alsusarip
11.10.2020 11:02

from math import sqrt, trunc

def isPrime(n):

   if (n < 2):

       return False

   for i in range(2, trunc(sqrt(n) + 1)):

       if n % i == 0:

           return False

   return True

print(isPrime( int(input()) ))

0,0(0 оценок)
Ответ:
Dii02
Dii02
11.10.2020 11:02

#Сама функция

def IsPrime(number):

   if number is 1: return False

   for i in range(2, number):

       if number % i == 0: return False  

   return True

#Вызов

print(IsPrime(int(input(

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?