В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
DashaKarg3
DashaKarg3
08.05.2020 20:05 •  Информатика

Дано трехзначное число. Написать программу, которая вычисляет сумму его цифр.

Ответ:
гоша206
гоша206
11.10.2020 10:07

Var sum, a, a1, a2, a3:integer;

Begin

Writeln('Введите трехзначное число');

Readln(a);

a1:=a div 100 ;

a2:=(a div 10) mod 10 ;

a3:=a mod 10;

sum:=a1+a2+a3;

Writeln(sum);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?