В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Паскаль

дан возраст человека в годах (0..99 лет). написать программу, которая называет возраст по-. например: если ввести «1», то программа должна выдать - «1 год», если ввести «22», то программа должна выдать - «22 года», если ввести «45», то программа должна выдать - «45 лет», и так для каждого числа в диапазоне от 0 до 99. разрешается использовать в программе не более 5 операторов if.

Ответ:
Дракончик22
Дракончик22
11.10.2020 04:15

Program vozrast;

var x,y : integer;

var godik: string;

Begin

readln(x);

y:=x mod 10;  

if (y=0) or (y>=5) then godik:='Лет';

if (y=1)  then godik:='Год';

if (y>=2) and (y<=4)  then godik:='Года';

if (x>=11) and (x<=14) then godik:='Лет';

writeln(x,' ',godik);

End.

0,0(0 оценок)
Ответ:
gadzila1236
gadzila1236
11.10.2020 04:15

program gg;

var e:integer;

begin

writeln ('Введите возраст');

read (e);

if e > 99 then

writeln ('Введите возраст до 99 лет')

else if (e mod 10 = 1) and (e <> 11) then

writeln (e,' год')

else if (e >= 2) and (e <= 4) or (e mod 10 = 2) or (e mod 10 = 3) or (e mod 10 = 4) then

writeln (e,' года')

else if (e >= 5) and (e <= 150) then

writeln (e,' лет')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?