В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
linaangel20012
linaangel20012
17.10.2020 18:04 •  Информатика

Написать программу на языке c++ с процедур
напишите процедуру, которая выводит на экран запись переданного ей числа в
римской системе счисления.
введите натуральное число:
mmxiii
буду

Ответ:
толик14
толик14
11.10.2020 04:13

Дак это уже было написано тысячу раз...

static void Rom(int N) {

string out="";

string rom[] = { "M", "CM", "D", "CD", "C", "XC", "L", "XL", "X", "IX", "V", "IV", "I" };

int dec[] = { 1000, 900, 500, 400, 100, 90, 50, 40, 10, 9, 5, 4, 1 };

while (N > 0) {

   int i = 0;

   while (N < dec[i]) i++;

   out+=rom[i];

   N -= dec[i];

}

cout << out;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?