В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ahmedov2007
ahmedov2007
25.06.2022 11:10 •  Информатика

Написать программу, которая определяет сколько единиц в числе, которое ввёл пользователь. например, в числе 197313 – две единицы. ( циклом)

Ответ:
aalenka592
aalenka592
11.10.2020 03:05

program p1;

var n,k1:integer;

begin

k1:=0;

write ('Введите число ');

readln (n);

write ('Количество единиц в числе ',n,' равно ');

repeat

if n mod 10 = 1 then k1:=k1+1;

n:=n div 10;

until n=0;

write(k1);

end.

0,0(0 оценок)
Ответ:
saule19611225
saule19611225
11.10.2020 03:05

На python:

Объяснение:

a = input("Введите число: ")

b = 0

for i in list(a):

   if i == '1':

       b += 1

print("'1' - ", b)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?