В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Svinhaa
Svinhaa
17.03.2023 12:33 •  Информатика

Напишите программу (в паскаль), которая выведет на печать сумму четных цифр числа и сумму нечетных цифр числа. программа получает на вход натуральное число.

Ответ:
Annala1
Annala1
11.10.2020 02:34

Объяснение:

Var s,n:integer;

Begin

   write('Введите число: ');readln(n);

   s:=0;

   While n<>0 do

    Begin

     if n mod 10 mod 2 = 0 then s:=s+n mod 10;

     n:=n div 10;

    End;

   if s<>0 then writeln('Сумма четных цифр: ',s)

    else writeln('Нету четных цифр в числе');

   readln;

End.

Может быть неправильной.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?