В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
akhmetova1
akhmetova1
16.01.2023 23:14 •  Информатика

Написать программу по информатике (можно на pascal или на c++)!
количество минимумов
найдите количество минимальных элементов в последовательности.

входные данные

вводится натуральное число n, а затем n чисел.

выходные данные

выведите количество минимальных элементов.
например :
мы вводим :
3
21
11
4
на выходе получаем : 1​

Ответ:
denisgulinskii
denisgulinskii
11.10.2020 00:04

#include <iostream>

using namespace std;

void main(){

int N, a, min, cmin;

cin >> N;

cin >> min;

cmin = 1;

for(int i=1; i<N;i++){

cin >> a;

if(min==a)

cmin++;

if(min>a){

min = a;

cmin = 1;

}

}

cout << cmin;

}

0,0(0 оценок)
Ответ:
dhvcn
dhvcn
11.10.2020 00:04

PascalABC.NET (Обязательно .NET, используется библиотека классов .NET)

begin

 var list: List<integer> := new List<integer>;

 var N := ReadInteger();

 for var i := 1 to N do

 begin

   list.Add(ReadInteger());

 end;

 

 list.Where(x -> x = list.Min()).Count.Println();

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?