В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
GeliaSecret2005
GeliaSecret2005
25.07.2020 04:32 •  Информатика

информатика 9 класс, паскаль
с клавиатуры вводится строка s. составьте программу, которая удаляет из строки все знаки тире и пробелы​

Ответ:
elizavetava
elizavetava
21.12.2023 11:09
Конечно! Для решения данной задачи вам понадобится использовать цикл и условие.

Вот программа на языке Паскаль, которая удаляет все знаки тире и пробелы из введенной строки:

```pascal
program deleteChars;

var
s, newString: string;
i: integer;

begin
// Вводим строку
writeln('Введите строку: ');
readln(s);

// Проходим по каждому символу строки
for i := 1 to length(s) do
begin
// Проверяем, является ли символ знаком тире или пробелом
if (s[i] <> '-') and (s[i] <> ' ') then
begin
// Если символ не является знаком тире или пробелом,
// добавляем его в новую строку
newString := newString + s[i];
end;
end;

// Выводим полученную новую строку
writeln('Строка после удаления знаков тире и пробелов: ', newString);

readln;
end.
```

В данной программе мы сначала вводим строку с клавиатуры с помощью функции `readln`. Затем мы проходим по каждому символу строки с помощью цикла `for`.

Внутри цикла проверяем, является ли текущий символ знаком тире или пробелом с помощью конструкции `if`. Если символ не является знаком тире или пробелом, мы добавляем его в новую строку.

В конце программы выводим полученную новую строку с помощью функции `writeln`.

Надеюсь, это помогло! Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?