В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

1.дан массив натуральных чисел. найти сумму элементов, кратных данному к. написать программу в питоне

Ответ:
rano09
rano09
10.10.2020 20:27

Program num1;

Uses crt;

Var

a :array [1..100] of integer;

i,k,n, s : integer;

Begin

clrscr;

s:=0;

write('K=');readln(k);

write('N=');readln(n);

for i:=1 to n do 

readln(a[i]);

for i:=1 to n do

if (a[i] MOD k)=0 then s:=s+a[i];

writeln('S=',s);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?