В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Kovalenko2001N
Kovalenko2001N
13.09.2021 21:03 •  Информатика

Написать программу в python

задан двумерный массив а из 3-х строк и 5-и столбцов. составить программу, которая организует одномерный массив, каждый элемент которого есть количество положительных элементов исходного массива в столбце. вычислить произведение элементов полученного массива.

Ответ:
отличник737
отличник737
10.10.2020 20:27

Объяснение:

Обозначим заданный двумерный массив через A, искомый одномерный - через В, произведение всех элементов этого массива - M. Тогда:

B=[ ]

M=1

for i in range(5):

   n=0

   for j in range(3):

       if A[ j ][ i ]>0:

           n+=1

   B.append(n)

   M*=n

print(B,M)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?