В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ismail00
ismail00
15.04.2021 22:57 •  Информатика

Составить программу, которая выводит все натуральные числа до 100 и кратных 5.​

Ответ:
sonya20067
sonya20067
11.08.2020 20:08

ответ:Pascal ABC.NET

var i:integer;

begin

for i:=1 to 100 do

if i mod 5=0 then write(i:4);

end.

0,0(0 оценок)
Ответ:
grabon12312
grabon12312
11.08.2020 20:08

===== PascalABC.NET =====

begin

 var i := 5;

 while i <= 100 do

 begin

   Print(i);

   i += 5

 end

end.

Объяснение:

Понятно, первое натуральное число, кратное 5 - это 5. Все прочие должны получаться прибавлением 5 к предыдущему, т.е. это числа 10, 15, 20, ... 95. Входит ли в эти числа 100, из условия непонятно. Обычно, чтобы не было двусмысленности, для указания включения 100 в диапазон значений используют термины "не более 100", "до 100 включительно",  "не превышающие 100", а "до 100" понимают как "меньше 100", т.е. как указание, что 100 включать не нужно.

Программа написана для случая, когда 100 включается в диапазон Если число 100 включать не нужно, в операторе whiie i <= 100 do из условия <= удалите знак равенства =.


Составить программу, которая выводит все натуральные числа до 100 и кратных 5.​
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?