В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
konoval1i
konoval1i
25.02.2022 10:22 •  Информатика

Склавиатуры вводится строка. составьте программу, которая «переворачивает» строку. пример: входные данные: кит; выходные данные: тик. только решение не такое, как здесь, нужно подробное.

Ответ:
vlad199411003
vlad199411003
10.10.2020 19:50

program Hello;

var a,k:string;

var i:integer;

begin

 read(a);

 for i:=0 to length(a) do begin

   k := k+a[length(a)-i];    

 end;

 write(k);

end.

Объяснение:

заводим две переменных типа string(строковой тип данных)

а и к

и еще не забудем счетчик для цикла i

строковой тип данных это массив из символов,то есть мы можем извлекать из него элементы с цикла

объявим цикл for от 0 до длины нашей строки,которую возвращает функция length() и с конкатенации(сложения строк,например: 'a'+'b'= 'ab) добавляем к новой строке "к"  элемент length()-i строки а.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?