В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
charaX
charaX
30.04.2021 09:45 •  Информатика

Написать программу, которая проверяет, находится ли введенное с клавиатуры число в массиве.

массив должен вводиться во время работы программы. (pascal abc)

Ответ:
Бегемот505
Бегемот505
10.10.2020 19:45

const n=8;

var a: array[1..n] of integer;

c,i: integer;

f: boolean;

begin

f:=false;

writeln('введите массив из ',n,' элементов:');

for i:=1 to n do readln(a[i]);

write('введите число: ');

read(c);

for i:=1 to n do if a[i]=c then begin

f:=true;

break;

end;

if(f) then write('введенное число находится в массиве')

else write('введенное число не находится в массиве');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?