В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Julyash
Julyash
23.11.2020 20:21 •  Информатика

Дана строка. надо написать программу, определяющую, какой символ "а" или "б" встречается чаще. (паскаль)

Ответ:
Shokzzz
Shokzzz
10.10.2020 19:11

Объяснение:

Var a,b,x,k,j : Integer;

Begin

Read (a);

Read(b);

Read(x);

While x<>0 do

Begin

If x mod 10=a then k:=k+1;

If x mod 10=b then j:=j+1;

X:=x div 10;

End;

If k=j then WriteLn('одинаковое количество ');

If k>j then WriteLn(символов а больше)

Else

WriteLn (символов b больше)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?