В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Вано153
Вано153
04.05.2023 13:18 •  Информатика

Напишите программу, которая вычисляет сумму первых n натуральных чисел.
в паскале через for i: = 1 to do

Ответ:
Добрыйдемон13
Добрыйдемон13
10.10.2020 17:59

const l=20;

var a:array[1..l] of integer;

i,n,s:integer;

begin

writeln('Сгенерированный массив: ');

for i:=1 to l do begin

a[i]:=random (101);

write(a[i]:4);

end;

writeln;

s:=0;

writeln('Введите n');

read(n);

for i:=1 to n do

s:=s+a[i];

writeln;

write('Сумма: ',s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?