В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Angelina13112003
Angelina13112003
06.01.2022 21:05 •  Информатика

Напишите программы на pascalabc.net
№5:
напишите программу, которая в последовательности натуральных чисел определяет среднее значение нечетных чисел, которые меньше 50. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести одно число: среднее значение четных чисел меньших 50.
например: 23 118 11 48 15 34 0 ==> 16.33
(вывод два знака после запятой)

Ответ:
Даниссиммо1
Даниссиммо1
10.10.2020 17:06

begin

 Write(ReadSeqIntegerWhile(p -> p <> 0)

   .Where(p -> p.IsOdd and p.InRange(1,49))

   .DefaultIfEmpty

   .Average:0:2)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?